Справка

Содержание

  • Назначение программы
  • Оборудование
  • Выбор СОМ-порта
  • Ввод ключа активации
  • Рассылка СМС
    • Создание списка номеров
    • Текст СМС
    • Сохранение списка номеров в базу данных
    • Одновременная рассылка на нескольких устройствах
    • Запуск рассылки СМС
    • Журнал отправки СМС
    • Управление списками номеров
  • Прием СМС
    • Включение/выключение приема СМС
    • Журнал принятых СМС
    • Уведомление о приходе новой СМС

Назначение программы

Программа «Рассылка и прием СМС SpRobot» предназначена для оповещения списка абонентов посредством СМС, а также для приема входящих СМС.

Оборудование

Для работы программы необходимо наличие GSM-устройства (мобильный телефон, GSM-модем или шлюз), подключенного к компьютеру.

Выбор СОМ-порта

При первом запуске программы выберите СОМ-порт, через который происходит коммуникация с GSM-устройством. Для этого в меню программы выберите пункт «Система\Выбрать GSM-шлюз...», в появившемся окне выберите из списка СОМ-порт и протестируйте соединение. В случае неудачи выполните тест для другого СОМ-порта. Если тест прошел успешно, то нажмите кнопку «Выбрать».

Ввод ключа активации

Без ключа активации программа работает следующим образом:

  1. Рассылка СМС без уведомления о доставке - неограничено.
  2. Рассылка СМС с уведомлением о доставке - ограничено до 10 СМС за один сеанс рассылки.
  3. Прием СМС - ограничено до 10 СМС за один сеанс приема.
После ввода ключа активации все ограничения снимаются. Чтобы получить ключ активации, сообщите IMEI вашего GSM-устройства продавцу «Рассылки и приема СМС SpRobot» (IMEI можно посмотреть в документах/на коробке/на корпусе устройства, а также в окне «Выбрать GSM-шлюз...», в логе АТ-команд). После этого вам будет выдан ключ, выписанный на IMEI конкретного GSM-устройства. Далее в меню программы выберите пункт «Система\Ввести ключ активации...», в появившемся окне вставьте ключ и нажмите кнопку «Активировать».

Рассылка СМС

Создание списка номеров

После запуска программы список номеров пуст. Этот список можно заполнить тремя способами:

  1. создать список вручную;
  2. импортировать из CSV-файла;
  3. загрузить сохраненный список из базы данных.

1. Для добавления строки или столбца необходимо нажать на панели инструментов кнопки [image] и [image] соответственно. После добавления заполните новые ячейки необходимыми значениями. Первым символом всегда должен быть код страны (для России цифра «7» или «8» ). Символ «+» впереди номера не обязателен. Удаление строки или столбца выполняется нажатием кнопок [image] и [image] соответственно.

2. CSV-файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Первый столбец в CSV-файле обязательно должен содержать номер абонента. Последующие столбцы необязательны и могут содержать любые данные. Чтобы загрузить список номеров из CSV-файла, нажмите на панели инструментов кнопку [image] (импорт списка). Также список номеров, содержащийся в программе, можно сохранить в CSV-файле (экспорт списка). Экспорт выполняется нажатием кнопки [image].

3. Программа рассылки имеет собственную базу данных, в которой содержатся списки номеров. Чтобы загрузить список, нажмите [image], сохранить список - нажмите [image].

Чтобы очистить список номеров и текст СМС в программе, нажмите [image]. Создание нового списка выполняется нажатием кнопки [image]. Проверить список номеров - нажмите [image].

Текст СМС

В поле «Текст сообщения» необходимо ввести текст СМС, который будет рассылаться абонентам. Этот текст может включать данные из списка номеров (если есть столбцы «N1», «N2» и т.д). Например, можно составить список номеров абонентов с их задолженностью: столбец «Номер» будет содержать номер абонента, а столбец «N1» - задолженность. Тогда текст СМС можно составить примерно так: «Ваша задолженность [№1]». При отправке СМС на очередной номер из списка программа будет брать значение из столбца «N1» для данного номера и вставлять его вместо символов «[№1]». Вставить шаблон «[№_]» можно вручную или вызвав контекстное меню нажатием правой кнопкой мыши.

Сохранение списка номеров в базу данных

Прежде чем рассылать СМС, необходимо сохранить список номеров в БД. Для этого нажмите на панели инструментов кнопку [image].

Одновременная рассылка на нескольких устройствах

На одном компьютере можно рассылать СМС по нескольким шлюзам одновременно (до 20 включительно). Для этого запустите столько экземпляров программы, сколько шлюзов вы будете использовать для рассылки СМС. Соответственно, в каждом экземпляре программы выберите шлюз, который еще не используется в других экземплярах. При одновременной рассылке СМС по нескольким шлюзам есть следующие ограничения:

  1. каждый экземпляр может обрабатывать только 1 список номеров, который не обрабатывается в других экземплярах;
  2. во время обработки некоторого списка номеров другие экземпляры программы не могут изменять/удалять этот список.

Запуск рассылки СМС

Чтобы начать рассылку, нажмите кнопку [image] на панели инструментов или выберите в меню программы пункт «Система\Запуск рассылки...».

В появившемся окне укажите подходящие настройки для рассылки СМС:

  • Пауза между СМС (сек.). Во время рассылки после каждой отправленной СМС будут выдержана указанная здесь пауза.
  • Запросить отчет о доставке. Во время рассылки программа будет запрашивать и ждать отчетов о доставке каждой СМС. В этом случае рассылка будет проходить в 2 этапа: непосредственно рассылка и ожидание отчетов о доставке.
  • После рассылки ждать отчеты о доставке (мин.). Здесь указывается максимальная длительность второго этапа. Если придут отчеты для всех отправленных СМС, то этап ожидания завершится досрочно. Если отчет придет после окончания второго этапа (истекло время ожидания), то отчет не будет зафиксирован в программе.
Для начала рассылки нажмите кнопку «Старт». Чтобы остановить рассылку, нажмите кнопку «Стоп». Во время рассылки также работает прием СМС.

Если во время передачи СМС возникнет ошибка, то программа попытается послать СМС еще 2 раза. Если в итоге все 3 попытки завершились ошибкой, то такой номер в разделе «Статистика» учитывается только в строке «Обработано», программа переходит к следующему номеру из списка. При следующем запуске рассылки программа спросит вас продолжить рассылку, обработав только необработанные и обработанные с ошибкой номера, или начать рассылку всего списка заново.

После окончания рассылки можно просмотреть Журнал отправки СМС, нажав на кнопку «Журнал». При этом в Журнале будут отображаться данные, относящиеся только к последней рассылке СМС.

Журнал отправки СМС

В Журнале можно увидеть результаты отправки СМС и отчеты о доставке. Смысл большинства столбцов понятен из их названия. Однако некоторые столбцы требуют пояснения:
  • ИД номера. Если СМС настолько длинная, что разделяется при отправке на несколько частей, то и отчеты о доставке относятся не ко всей СМС, а к каждой отправленной части. Чтобы определить, доставлена ли СМС полностью, нужно посмотреть результат отправки и доставки для всех строк с одинаковым «ИД номера».
  • Результат доставки. Может принимать 4 значения:
    • Доставлено.
      • Отчет получен, СМС успешно доставлено абоненту.
    • Временная ошибка.
      • Отчет получен, СМС не доставлено абоненту, но оператор связи будет дальше пытаться доставить СМС.
    • Не доставлено.
      • Отчет получен, СМС не доставлено. Оператор связи не будет пытаться доставить СМС абоненту.
    • Отчет не получен.
      • Отчет о результате доставки (т.е. одно из 3 предыдущих значений) еще не пришел.
  • Время отправки, Время доставки. Время отправки указывается относительно компьютера, на котором работает программа. В время доставки - относительно оператора связи. Поэтому значения в этих столбцах могут быть «нелогичными», например время доставки может быть раньше времени отправки. Иногда такая проблема решается после синхронизации времени компьютера через Интернет.
Данные из Журнала можно сохранить в файл. Для этого нажмите на панели инструментов кнопку [image]. Сохраненный файл можно открыть в программах Microsoft Excel, OpenOffice\LibreOffice Calc.
Кнопка [image] обновляет данные в Журнале.
Для удаления данных из Журнала нажмите кнопку [image]. При этом удаляются строки, соответствующие выбранному фильтру. Если ранее фильтр не был установлен, то удалятся все данные из Журнала.
Чтобы уменьшить количество отображаемых строк в Журнале, установите фильтр. Для этого нажмите кнопку [image], которая откроет окно с параметрами фильтра. Чтобы сбросить фильтр и просмотреть все записи Журнала, нажмите кнопку [image].

В полях «Номер» и «Текст СМС» можно указать конкретное значение или шаблон (маску). В последнем случае нужно использовать символы «%» (любые символы в любом количестве, включая 0 символов) и «_» (любой один символ).

Управление списками номеров

С помощью меню «Система\Управление списками...» открывается окно «Управление списками номеров». В нем отображаются списки номеров, которые содержатся в базе данных программы. Также в этом окне можно изменять имя списка (кнопка [image]) или удалить список из базы данных (кнопка [image]).

Прием СМС

Включение/выключение приема СМС

Включение приема СМС производится кнопкой [image] на панели инструментов или выбором пункта меню «Прием СМС\Включить». Принятые СМС сохраняются в базе данных программы. Сразу после включения программа проверяет в памяти GSM-устройства наличие входящих СМС. Если эти СМС отсутствуют в базе данных, то они будут сохранены. После проверки памяти и после получения очередной СМС все сообщения удаляются из GSM-устройства.

Выключение приема СМС производится кнопкой [image] или выбором пункта меню "Прием СМС\Выключить".

Журнал принятых СМС

Принятые СМС можно посмотреть в Журнале. Для этого нажмите кнопку [image] (в меню пункт «Прием СМС\Открыть журнал принятых СМС...»).

Сокращенный вид Журнала:

Полный вид Журнала:

Пояснения для некоторых столбцов:
  • Время получения. Время, когда программа приняла СМС от GSM-устройства. Указывается относительно компьютера, на котором работает программа.
  • Время получения СЦ. Время, когда Сервис-Центр (оператор сотовой связи) получил СМС от абонента. Указывается относительно Сервис-Центра. Иногда может значительно отличаться от времени получения.
  • Время старта приема. Это время обозначает начало сеанса приема входящих СМС. Сеанс начинается и заканчивается после включения и выключения приема соответственно.
  • Номер СЦ. Номер Сервис-Центра (оператора сотовой связи), отправившего сообщение.
Данные из Журнала можно сохранить в файл. Для этого нажмите на панели инструментов кнопку [image]. Сохраненный файл можно открыть в программах Microsoft Excel, OpenOffice\LibreOffice Calc.
Кнопка [image] обновляет данные в Журнале.
Для удаления данных из Журнала нажмите кнопку [image]. При этом удаляются строки, соответствующие выбранному фильтру. Если ранее фильтр не был установлен, то удалятся все данные из Журнала.
Чтобы уменьшить количество отображаемых строк в Журнале, установите фильтр. Для этого нажмите кнопку [image], которая откроет окно с параметрами фильтра. Чтобы сбросить фильтр и просмотреть все записи Журнала, нажмите кнопку [image].

В полях «Номер», «Номер СЦ» и «Текст СМС» можно указать конкретное значение или шаблон (маску). В последнем случае нужно использовать символы «%» (любые символы в любом количестве, включая 0 символов) и «_» (любой один символ).

Уведомление о приходе новой СМС

Программа уведомляет пользователя о приходе СМС с помощью звукового сигнала, мигания окна программы и значка на панели задач, а также с помощью всплывающего окна.

Пример всплывающего окна:

Параметры и способы уведомления настраиваются через пункт меню «Прием СМС\Параметры уведомления».